aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/patches-5.10/217-ARM-at91-sama7-introduce-sama7-SoC-family.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/patches-5.10/217-ARM-at91-sama7-introduce-sama7-SoC-family.patch')
-rw-r--r--target/linux/at91/patches-5.10/217-ARM-at91-sama7-introduce-sama7-SoC-family.patch71
1 files changed, 71 insertions, 0 deletions
diff --git a/target/linux/at91/patches-5.10/217-ARM-at91-sama7-introduce-sama7-SoC-family.patch b/target/linux/at91/patches-5.10/217-ARM-at91-sama7-introduce-sama7-SoC-family.patch
new file mode 100644
index 0000000000..de38988237
--- /dev/null
+++ b/target/linux/at91/patches-5.10/217-ARM-at91-sama7-introduce-sama7-SoC-family.patch
@@ -0,0 +1,71 @@
+From dea645bce478cc72a2bf2413ec873927d1471442 Mon Sep 17 00:00:00 2001
+From: Eugen Hristev <eugen.hristev@microchip.com>
+Date: Thu, 15 Apr 2021 13:50:08 +0300
+Subject: [PATCH 217/247] ARM: at91: sama7: introduce sama7 SoC family
+
+Introduce new family of SoCs, sama7, and first SoC, sama7g5.
+
+Signed-off-by: Eugen Hristev <eugen.hristev@microchip.com>
+[claudiu.beznea@microchip.com: keep only the sama7_dt]
+Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
+Signed-off-by: Nicolas Ferre <nicolas.ferre@microchip.com>
+Link: https://lore.kernel.org/r/20210415105010.569620-23-claudiu.beznea@microchip.com
+---
+ arch/arm/mach-at91/Makefile | 1 +
+ arch/arm/mach-at91/sama7.c | 32 ++++++++++++++++++++++++++++++++
+ 2 files changed, 33 insertions(+)
+ create mode 100644 arch/arm/mach-at91/sama7.c
+
+diff --git a/arch/arm/mach-at91/Makefile b/arch/arm/mach-at91/Makefile
+index f565490f1b70..522b680b6446 100644
+--- a/arch/arm/mach-at91/Makefile
++++ b/arch/arm/mach-at91/Makefile
+@@ -8,6 +8,7 @@ obj-$(CONFIG_SOC_AT91RM9200) += at91rm9200.o
+ obj-$(CONFIG_SOC_AT91SAM9) += at91sam9.o
+ obj-$(CONFIG_SOC_SAM9X60) += sam9x60.o
+ obj-$(CONFIG_SOC_SAMA5) += sama5.o
++obj-$(CONFIG_SOC_SAMA7) += sama7.o
+ obj-$(CONFIG_SOC_SAMV7) += samv7.o
+
+ # Power Management
+diff --git a/arch/arm/mach-at91/sama7.c b/arch/arm/mach-at91/sama7.c
+new file mode 100644
+index 000000000000..19d7bcbc97f1
+--- /dev/null
++++ b/arch/arm/mach-at91/sama7.c
+@@ -0,0 +1,32 @@
++// SPDX-License-Identifier: GPL-2.0-or-later
++/*
++ * Setup code for SAMA7
++ *
++ * Copyright (C) 2021 Microchip Technology, Inc. and its subsidiaries
++ *
++ */
++
++#include <linux/of.h>
++#include <linux/of_platform.h>
++
++#include <asm/mach/arch.h>
++#include <asm/system_misc.h>
++
++#include "generic.h"
++
++static void __init sama7_dt_device_init(void)
++{
++ of_platform_default_populate(NULL, NULL, NULL);
++}
++
++static const char *const sama7_dt_board_compat[] __initconst = {
++ "microchip,sama7",
++ NULL
++};
++
++DT_MACHINE_START(sama7_dt, "Microchip SAMA7")
++ /* Maintainer: Microchip */
++ .init_machine = sama7_dt_device_init,
++ .dt_compat = sama7_dt_board_compat,
++MACHINE_END
++
+--
+2.32.0
+