aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/image/sama5d4.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/image/sama5d4.mk')
-rw-r--r--target/linux/at91/image/sama5d4.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/at91/image/sama5d4.mk b/target/linux/at91/image/sama5d4.mk
new file mode 100644
index 0000000000..554b9890df
--- /dev/null
+++ b/target/linux/at91/image/sama5d4.mk
@@ -0,0 +1,19 @@
+
+define Device/default-nand
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
+endef
+
+define Device/at91-sama5d4_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
+ KERNEL_SIZE := 6144k
+ BLOCKSIZE := 256k
+ PAGESIZE := 4096
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082 -x lzo
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d4_xplained