aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.14/818-MIPS-ath79-add-nu801-led-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-4.14/818-MIPS-ath79-add-nu801-led-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-4.14/818-MIPS-ath79-add-nu801-led-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-4.14/818-MIPS-ath79-add-nu801-led-driver.patch b/target/linux/ar71xx/patches-4.14/818-MIPS-ath79-add-nu801-led-driver.patch
new file mode 100644
index 0000000000..337447e2bf
--- /dev/null
+++ b/target/linux/ar71xx/patches-4.14/818-MIPS-ath79-add-nu801-led-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -606,6 +606,13 @@ config LEDS_IS31FL32XX
+
+ comment "LED driver for blink(1) USB RGB LED is under Special HID drivers (HID_THINGM)"
+
++config LEDS_NU801
++ tristate "LED driver for NU801 RGB LED"
++ depends on LEDS_CLASS && (ATH79_MACH_MR18 || ATH79_MACH_Z1)
++ help
++ This option enables support for NU801 RGB LED driver chips
++ accessed via GPIO.
++
+ config LEDS_BLINKM
+ tristate "LED support for the BlinkM I2C RGB LED"
+ depends on LEDS_CLASS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -56,6 +56,7 @@ obj-$(CONFIG_LEDS_ADP5520) += leds-adp5
+ obj-$(CONFIG_LEDS_DELL_NETBOOKS) += dell-led.o
+ obj-$(CONFIG_LEDS_MC13783) += leds-mc13783.o
+ obj-$(CONFIG_LEDS_RB750) += leds-rb750.o
++obj-$(CONFIG_LEDS_NU801) += leds-nu801.o
+ obj-$(CONFIG_LEDS_NS2) += leds-ns2.o
+ obj-$(CONFIG_LEDS_NETXBIG) += leds-netxbig.o
+ obj-$(CONFIG_LEDS_ASIC3) += leds-asic3.o