aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-3.10')
-rw-r--r--target/linux/ar71xx/patches-3.10/401-mtd-physmap-add-lock-unlock.patch2
-rw-r--r--target/linux/ar71xx/patches-3.10/406-mtd-m25p80-allow-to-specify-max-read-size.patch2
-rw-r--r--target/linux/ar71xx/patches-3.10/407-mtd-m25p80-allow-to-pass-probe-types-via-platform-data.patch2
-rw-r--r--target/linux/ar71xx/patches-3.10/412-mtd-m25p80-zero-partition-parser-data.patch2
-rw-r--r--target/linux/ar71xx/patches-3.10/500-MIPS-fw-myloader.patch2
-rw-r--r--target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch24
6 files changed, 14 insertions, 20 deletions
diff --git a/target/linux/ar71xx/patches-3.10/401-mtd-physmap-add-lock-unlock.patch b/target/linux/ar71xx/patches-3.10/401-mtd-physmap-add-lock-unlock.patch
index 953ae58da3..b8b4e67b15 100644
--- a/target/linux/ar71xx/patches-3.10/401-mtd-physmap-add-lock-unlock.patch
+++ b/target/linux/ar71xx/patches-3.10/401-mtd-physmap-add-lock-unlock.patch
@@ -83,7 +83,7 @@
for (; info->mtd[i] == NULL && *probe_type != NULL; probe_type++)
--- a/include/linux/mtd/physmap.h
+++ b/include/linux/mtd/physmap.h
-@@ -26,6 +26,8 @@ struct physmap_flash_data {
+@@ -25,6 +25,8 @@ struct physmap_flash_data {
unsigned int width;
int (*init)(struct platform_device *);
void (*exit)(struct platform_device *);
diff --git a/target/linux/ar71xx/patches-3.10/406-mtd-m25p80-allow-to-specify-max-read-size.patch b/target/linux/ar71xx/patches-3.10/406-mtd-m25p80-allow-to-specify-max-read-size.patch
index 8dfad61e63..442d1b76de 100644
--- a/target/linux/ar71xx/patches-3.10/406-mtd-m25p80-allow-to-specify-max-read-size.patch
+++ b/target/linux/ar71xx/patches-3.10/406-mtd-m25p80-allow-to-specify-max-read-size.patch
@@ -84,7 +84,7 @@
mutex_unlock(&flash->lock);
return 0;
-@@ -1021,6 +1044,12 @@ static int m25p_probe(struct spi_device
+@@ -1017,6 +1040,12 @@ static int m25p_probe(struct spi_device
flash->mtd._unlock = m25p80_unlock;
}
diff --git a/target/linux/ar71xx/patches-3.10/407-mtd-m25p80-allow-to-pass-probe-types-via-platform-data.patch b/target/linux/ar71xx/patches-3.10/407-mtd-m25p80-allow-to-pass-probe-types-via-platform-data.patch
index dd38f0085c..5e7d627f42 100644
--- a/target/linux/ar71xx/patches-3.10/407-mtd-m25p80-allow-to-pass-probe-types-via-platform-data.patch
+++ b/target/linux/ar71xx/patches-3.10/407-mtd-m25p80-allow-to-pass-probe-types-via-platform-data.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
-@@ -1121,7 +1121,9 @@ static int m25p_probe(struct spi_device
+@@ -1117,7 +1117,9 @@ static int m25p_probe(struct spi_device
/* partitions should match sector boundaries; and it may be good to
* use readonly partitions for writeprotected sectors (BP2..BP0).
*/
diff --git a/target/linux/ar71xx/patches-3.10/412-mtd-m25p80-zero-partition-parser-data.patch b/target/linux/ar71xx/patches-3.10/412-mtd-m25p80-zero-partition-parser-data.patch
index abec9b5b40..6d82f7b3b5 100644
--- a/target/linux/ar71xx/patches-3.10/412-mtd-m25p80-zero-partition-parser-data.patch
+++ b/target/linux/ar71xx/patches-3.10/412-mtd-m25p80-zero-partition-parser-data.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
-@@ -1071,6 +1071,7 @@ static int m25p_probe(struct spi_device
+@@ -1067,6 +1067,7 @@ static int m25p_probe(struct spi_device
if (info->flags & M25P_NO_ERASE)
flash->mtd.flags |= MTD_NO_ERASE;
diff --git a/target/linux/ar71xx/patches-3.10/500-MIPS-fw-myloader.patch b/target/linux/ar71xx/patches-3.10/500-MIPS-fw-myloader.patch
index 999b466062..dff5fbe2bb 100644
--- a/target/linux/ar71xx/patches-3.10/500-MIPS-fw-myloader.patch
+++ b/target/linux/ar71xx/patches-3.10/500-MIPS-fw-myloader.patch
@@ -10,7 +10,7 @@
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -993,6 +993,9 @@ config MIPS_MSC
+@@ -998,6 +998,9 @@ config MIPS_MSC
config MIPS_NILE4
bool
diff --git a/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch b/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch
index ee41f655cc..231b487b82 100644
--- a/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch
+++ b/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch
@@ -1,8 +1,6 @@
-Index: linux-3.10.4/arch/mips/ath79/Kconfig
-===================================================================
---- linux-3.10.4.orig/arch/mips/ath79/Kconfig 2013-08-04 19:08:12.739921385 +0200
-+++ linux-3.10.4/arch/mips/ath79/Kconfig 2013-08-04 19:09:15.379922883 +0200
-@@ -254,6 +254,16 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -254,6 +254,16 @@ config ATH79_MACH_WPE72
select ATH79_DEV_USB
select MYLOADER
@@ -19,11 +17,9 @@ Index: linux-3.10.4/arch/mips/ath79/Kconfig
config ATH79_MACH_DIR_600_A1
bool "D-Link DIR-600 A1/DIR-615 E4 support"
select SOC_AR724X
-Index: linux-3.10.4/arch/mips/ath79/Makefile
-===================================================================
---- linux-3.10.4.orig/arch/mips/ath79/Makefile 2013-08-04 19:07:36.299920522 +0200
-+++ linux-3.10.4/arch/mips/ath79/Makefile 2013-08-04 19:09:42.363923523 +0200
-@@ -53,6 +53,7 @@
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -53,6 +53,7 @@ obj-$(CONFIG_ATH79_MACH_ARCHER_C7) += ma
obj-$(CONFIG_ATH79_MACH_AW_NR580) += mach-aw-nr580.o
obj-$(CONFIG_ATH79_MACH_CAP4200AG) += mach-cap4200ag.o
obj-$(CONFIG_ATH79_MACH_DB120) += mach-db120.o
@@ -31,11 +27,9 @@ Index: linux-3.10.4/arch/mips/ath79/Makefile
obj-$(CONFIG_ATH79_MACH_DIR_600_A1) += mach-dir-600-a1.o
obj-$(CONFIG_ATH79_MACH_DIR_615_C1) += mach-dir-615-c1.o
obj-$(CONFIG_ATH79_MACH_DIR_825_B1) += mach-dir-825-b1.o
-Index: linux-3.10.4/arch/mips/ath79/machtypes.h
-===================================================================
---- linux-3.10.4.orig/arch/mips/ath79/machtypes.h 2013-08-04 19:08:12.739921385 +0200
-+++ linux-3.10.4/arch/mips/ath79/machtypes.h 2013-08-04 19:09:29.715923222 +0200
-@@ -37,6 +37,7 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -37,6 +37,7 @@ enum ath79_mach_type {
ATH79_MACH_CARAMBOLA2, /* 8devices Carambola2 */
ATH79_MACH_DB120, /* Atheros DB120 reference board */
ATH79_MACH_PB44, /* Atheros PB44 reference board */