aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/tiny-senao.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/tiny-senao.mk')
-rw-r--r--target/linux/ar71xx/image/tiny-senao.mk28
1 files changed, 0 insertions, 28 deletions
diff --git a/target/linux/ar71xx/image/tiny-senao.mk b/target/linux/ar71xx/image/tiny-senao.mk
deleted file mode 100644
index 3a7f6776b3..0000000000
--- a/target/linux/ar71xx/image/tiny-senao.mk
+++ /dev/null
@@ -1,28 +0,0 @@
-define Build/senao-factory-image
- mkdir -p $@.senao
-
- touch $@.senao/FWINFO-OpenWrt-$(REVISION)-$(1)
- $(CP) $(IMAGE_KERNEL) $@.senao/openwrt-senao-$(1)-uImage-lzma.bin
- $(CP) $@ $@.senao/openwrt-senao-$(1)-root.squashfs
-
- $(TAR) -c \
- --numeric-owner --owner=0 --group=0 --sort=name \
- $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
- -C $@.senao . | gzip -9nc > $@
-
- rm -rf $@.senao
-endef
-
-
-define Device/ens202ext
- DEVICE_TITLE := EnGenius ENS202EXT
- BOARDNAME := ENS202EXT
- DEVICE_PACKAGES := rssileds
- KERNEL_SIZE := 1536k
- IMAGE_SIZE := 13632k
- IMAGES += factory.bin
- MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),320k(custom)ro,1536k(kernel),12096k(rootfs),2048k(failsafe)ro,64k(art)ro,13632k@0xa0000(firmware)
- IMAGE/factory.bin := append-rootfs | pad-rootfs | senao-factory-image ens202ext
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
-endef
-TARGET_DEVICES += ens202ext