aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 54f69b610b..ba7374ecc3 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -392,6 +392,25 @@ define Device/e600gac-v2-8M
endef
TARGET_DEVICES += e600gac-v2-8M
+define Device/e750a-v4-16M
+ DEVICE_TITLE := Qxwlan E750A v4 (16MB flash)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig
+ BOARDNAME := E750A-V4
+ SUPPORTED_DEVICES := e750a-v4
+ IMAGE_SIZE := 15936k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),64k(pri-data)ro,64k(art),-(firmware)
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += e750a-v4-16M
+
+define Device/e750a-v4-8M
+ $(Device/e750a-v4-16M)
+ DEVICE_TITLE := Qxwlan E750A v4 (8MB flash)
+ IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += e750a-v4-8M
+
define Device/ew-balin
DEVICE_TITLE := Embedded Wireless Balin Platform
DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea