aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch/mips
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/files/arch/mips')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt11
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-lima.c88
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
4 files changed, 101 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 4c00ea5a95..44f754c2bc 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -1822,6 +1822,17 @@ config ATH79_MACH_CARAMBOLA2
select ATH79_DEV_USB
select ATH79_DEV_WMAC
+config ATH79_MACH_LIMA
+ bool "8devices Lima board"
+ select SOC_QCA953X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_SPI
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+ select ATH79_DEV_ETH
+
config ATH79_MACH_CF_E316N_V2
bool "COMFAST CF-E316N v2 support"
select SOC_AR934X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index e0748b1237..f402463dfc 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -120,6 +120,7 @@ obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
obj-$(CONFIG_ATH79_MACH_JA76PF) += mach-ja76pf.o
obj-$(CONFIG_ATH79_MACH_JWAP003) += mach-jwap003.o
obj-$(CONFIG_ATH79_MACH_JWAP230) += mach-jwap230.o
+obj-$(CONFIG_ATH79_MACH_LIMA) += mach-lima.o
obj-$(CONFIG_ATH79_MACH_MC_MAC1200R) += mach-mc-mac1200r.o
obj-$(CONFIG_ATH79_MACH_MR12) += mach-mr12.o
obj-$(CONFIG_ATH79_MACH_MR16) += mach-mr16.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-lima.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-lima.c
new file mode 100644
index 0000000000..9c784f7921
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-lima.c
@@ -0,0 +1,88 @@
+/*
+ * 8devices Lima board support
+ *
+ * Copyright (C) 2016 Mantas Pucka <mantas@8devices.com>
+ * Copyright (C) 2017 Karol Dudek <karoiz@sli.pl>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+#include <asm/mach-ath79/ath79.h>
+
+#include "common.h"
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-spi.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "pci.h"
+
+#define LIMA_GPIO_BTN_1_DEFAULT 16
+#define LIMA_KEYS_POLL_INTERVAL 20 /* msecs */
+#define LIMA_KEYS_DEBOUNCE_INTERVAL (3 * LIMA_KEYS_POLL_INTERVAL)
+
+#define LIMA_ETH_PHYS (BIT(0) | BIT(1))
+
+#define LIMA_MAC0_OFFSET 0x0000
+#define LIMA_MAC1_OFFSET 0x0006
+
+#define LIMA_CALDATA_OFFSET 0x1000
+#define LIMA_WMAC_MAC_OFFSET 0x0800
+
+static struct gpio_keys_button lima_gpio_keys[] __initdata = {
+ {
+ .desc = "button1",
+ .type = EV_KEY,
+ .code = BTN_1,
+ .debounce_interval = LIMA_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = LIMA_GPIO_BTN_1_DEFAULT,
+ .active_low = 1,
+ }
+};
+
+static void __init lima_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1f080000);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_register_gpio_keys_polled(-1, LIMA_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(lima_gpio_keys),
+ lima_gpio_keys);
+
+ ath79_setup_ar933x_phy4_switch(true, true);
+
+ ath79_init_mac(ath79_eth0_data.mac_addr, art + LIMA_MAC0_OFFSET, 0);
+ ath79_init_mac(ath79_eth1_data.mac_addr, art + LIMA_MAC1_OFFSET, 0);
+
+ ath79_register_mdio(0, ~LIMA_ETH_PHYS);
+
+ ath79_switch_data.phy4_mii_en = 1;
+
+ ath79_switch_data.phy_poll_mask |= BIT(0);
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+ ath79_eth1_data.phy_mask = BIT(1);
+ ath79_register_eth(1);
+
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.duplex = DUPLEX_FULL;
+ ath79_eth0_data.speed = SPEED_100;
+ ath79_eth0_data.phy_mask = BIT(0);
+ ath79_register_eth(0);
+
+ ath79_register_wmac(art + LIMA_CALDATA_OFFSET,
+ art + LIMA_WMAC_MAC_OFFSET);
+ ath79_register_usb();
+ ath79_register_pci();
+}
+
+MIPS_MACHINE(ATH79_MACH_LIMA, "LIMA", "8devices Lima board", lima_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 69c848ef3d..39a80fc6fb 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -113,6 +113,7 @@ enum ath79_mach_type {
ATH79_MACH_JA76PF2, /* jjPlus JA76PF2 */
ATH79_MACH_JWAP003, /* jjPlus JWAP003 */
ATH79_MACH_JWAP230, /* jjPlus JWAP230 */
+ ATH79_MACH_LIMA, /* 8devices Lima */
ATH79_MACH_MC_MAC1200R, /* MERCURY MAC1200R */
ATH79_MACH_MR12, /* Cisco Meraki MR12 */
ATH79_MACH_MR16, /* Cisco Meraki MR16 */