aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.22
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar7/patches-2.6.22')
-rw-r--r--target/linux/ar7/patches-2.6.22/100-board_support.patch3
-rw-r--r--target/linux/ar7/patches-2.6.22/130-vlynq.patch20
2 files changed, 21 insertions, 2 deletions
diff --git a/target/linux/ar7/patches-2.6.22/100-board_support.patch b/target/linux/ar7/patches-2.6.22/100-board_support.patch
index b1577150c9..59fafa55a0 100644
--- a/target/linux/ar7/patches-2.6.22/100-board_support.patch
+++ b/target/linux/ar7/patches-2.6.22/100-board_support.patch
@@ -1,7 +1,7 @@
diff -urN linux-2.6.22/arch/mips/Kconfig linux-2.6.22.new/arch/mips/Kconfig
--- linux-2.6.22/arch/mips/Kconfig 2007-07-09 01:32:17.000000000 +0200
+++ linux-2.6.22.new/arch/mips/Kconfig 2007-07-11 02:34:51.000000000 +0200
-@@ -15,6 +15,22 @@
+@@ -15,6 +15,21 @@
prompt "System type"
default SGI_IP22
@@ -9,7 +9,6 @@ diff -urN linux-2.6.22/arch/mips/Kconfig linux-2.6.22.new/arch/mips/Kconfig
+ bool "Texas Instruments AR7"
+ select BOOT_ELF32
+ select DMA_NONCOHERENT
-+ select HW_HAS_PCI
+ select IRQ_CPU
+ select SWAP_IO_SPACE
+ select SYS_HAS_CPU_MIPS32_R1
diff --git a/target/linux/ar7/patches-2.6.22/130-vlynq.patch b/target/linux/ar7/patches-2.6.22/130-vlynq.patch
new file mode 100644
index 0000000000..2e8dea3ed9
--- /dev/null
+++ b/target/linux/ar7/patches-2.6.22/130-vlynq.patch
@@ -0,0 +1,20 @@
+Index: linux-2.6.22.4/drivers/Kconfig
+===================================================================
+--- linux-2.6.22.4.orig/drivers/Kconfig 2007-10-06 01:09:43.000000000 +0800
++++ linux-2.6.22.4/drivers/Kconfig 2007-10-06 01:12:19.000000000 +0800
+@@ -84,4 +84,6 @@
+
+ source "drivers/kvm/Kconfig"
+
++source "drivers/vlynq/Kconfig"
++
+ endmenu
+Index: linux-2.6.22.4/drivers/Makefile
+===================================================================
+--- linux-2.6.22.4.orig/drivers/Makefile 2007-10-06 01:09:43.000000000 +0800
++++ linux-2.6.22.4/drivers/Makefile 2007-10-06 01:12:37.000000000 +0800
+@@ -81,3 +81,4 @@
+ obj-$(CONFIG_DMA_ENGINE) += dma/
+ obj-$(CONFIG_HID) += hid/
+ obj-$(CONFIG_PPC_PS3) += ps3/
++obj-$(CONFIG_VLYNQ) += vlynq/