aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/airoha/patches-5.15/0003-add-airoha-en7523-gpio-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/airoha/patches-5.15/0003-add-airoha-en7523-gpio-driver.patch')
-rw-r--r--target/linux/airoha/patches-5.15/0003-add-airoha-en7523-gpio-driver.patch14
1 files changed, 5 insertions, 9 deletions
diff --git a/target/linux/airoha/patches-5.15/0003-add-airoha-en7523-gpio-driver.patch b/target/linux/airoha/patches-5.15/0003-add-airoha-en7523-gpio-driver.patch
index 1d95e6b2c8..319336257b 100644
--- a/target/linux/airoha/patches-5.15/0003-add-airoha-en7523-gpio-driver.patch
+++ b/target/linux/airoha/patches-5.15/0003-add-airoha-en7523-gpio-driver.patch
@@ -1,11 +1,9 @@
-diff --git a/drivers/gpio/Kconfig b/drivers/gpio/Kconfig
-index cbfb6f13..b3106df6 100644
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -247,6 +247,16 @@ config GPIO_EM
- help
- Say yes here to support GPIO on Renesas Emma Mobile SoCs.
-
+ help
+ Say yes here to support GPIO on Renesas Emma Mobile SoCs.
+
+config GPIO_EN7523
+ tristate "Airoha GPIO support"
+ depends on ARCH_AIROHA
@@ -17,10 +15,8 @@ index cbfb6f13..b3106df6 100644
+ Airoha EN7523 SoC. It supports two banks of 32 GPIOs.
+
config GPIO_EP93XX
- def_bool y
- depends on ARCH_EP93XX
-diff --git a/drivers/gpio/Makefile b/drivers/gpio/Makefile
-index 61202717..4c73ce82 100644
+ def_bool y
+ depends on ARCH_EP93XX
--- a/drivers/gpio/Makefile
+++ b/drivers/gpio/Makefile
@@ -57,6 +57,7 @@ obj-$(CONFIG_GPIO_DLN2) += gpio-dln2.o