aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch')
-rw-r--r--target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch16
1 files changed, 6 insertions, 10 deletions
diff --git a/target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch b/target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch
index 676e0f40bb..bae5cacc5e 100644
--- a/target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch
+++ b/target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch
@@ -1,11 +1,9 @@
-diff --git a/drivers/clk/Kconfig b/drivers/clk/Kconfig
-index c5b3dc97..c973ac1a 100644
--- a/drivers/clk/Kconfig
+++ b/drivers/clk/Kconfig
@@ -192,6 +192,15 @@ config COMMON_CLK_CS2000_CP
- help
- If you say yes here you get support for the CS2000 clock multiplier.
-
+ help
+ If you say yes here you get support for the CS2000 clock multiplier.
+
+config COMMON_CLK_EN7523
+ bool "Clock driver for Airoha EN7523 SoC system clocks"
+ depends on OF
@@ -16,13 +14,11 @@ index c5b3dc97..c973ac1a 100644
+ ARM silicon.
+
config COMMON_CLK_FSL_FLEXSPI
- tristate "Clock driver for FlexSPI on Layerscape SoCs"
- depends on ARCH_LAYERSCAPE || COMPILE_TEST
-diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
-index e4231212..be11d88c 100644
+ tristate "Clock driver for FlexSPI on Layerscape SoCs"
+ depends on ARCH_LAYERSCAPE || COMPILE_TEST
--- a/drivers/clk/Makefile
+++ b/drivers/clk/Makefile
-@@ -27,6 +27,7 @@ obj-$(CONFIG_COMMON_CLK_CDCE925) += clk-cdce925.o
+@@ -27,6 +27,7 @@ obj-$(CONFIG_COMMON_CLK_CDCE925) += clk-
obj-$(CONFIG_ARCH_CLPS711X) += clk-clps711x.o
obj-$(CONFIG_COMMON_CLK_CS2000_CP) += clk-cs2000-cp.o
obj-$(CONFIG_ARCH_SPARX5) += clk-sparx5.o