aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch')
-rw-r--r--target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch b/target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch
new file mode 100644
index 0000000000..676e0f40bb
--- /dev/null
+++ b/target/linux/airoha/patches-5.15/0002-add-airoha-en7523-clk-driver.patch
@@ -0,0 +1,32 @@
+diff --git a/drivers/clk/Kconfig b/drivers/clk/Kconfig
+index c5b3dc97..c973ac1a 100644
+--- a/drivers/clk/Kconfig
++++ b/drivers/clk/Kconfig
+@@ -192,6 +192,15 @@ config COMMON_CLK_CS2000_CP
+ help
+ If you say yes here you get support for the CS2000 clock multiplier.
+
++config COMMON_CLK_EN7523
++ bool "Clock driver for Airoha EN7523 SoC system clocks"
++ depends on OF
++ depends on ARCH_AIROHA || COMPILE_TEST
++ default ARCH_AIROHA
++ help
++ This driver provides the fixed clocks and gates present on Airoha
++ ARM silicon.
++
+ config COMMON_CLK_FSL_FLEXSPI
+ tristate "Clock driver for FlexSPI on Layerscape SoCs"
+ depends on ARCH_LAYERSCAPE || COMPILE_TEST
+diff --git a/drivers/clk/Makefile b/drivers/clk/Makefile
+index e4231212..be11d88c 100644
+--- a/drivers/clk/Makefile
++++ b/drivers/clk/Makefile
+@@ -27,6 +27,7 @@ obj-$(CONFIG_COMMON_CLK_CDCE925) += clk-cdce925.o
+ obj-$(CONFIG_ARCH_CLPS711X) += clk-clps711x.o
+ obj-$(CONFIG_COMMON_CLK_CS2000_CP) += clk-cs2000-cp.o
+ obj-$(CONFIG_ARCH_SPARX5) += clk-sparx5.o
++obj-$(CONFIG_COMMON_CLK_EN7523) += clk-en7523.o
+ obj-$(CONFIG_COMMON_CLK_FIXED_MMIO) += clk-fixed-mmio.o
+ obj-$(CONFIG_COMMON_CLK_FSL_FLEXSPI) += clk-fsl-flexspi.o
+ obj-$(CONFIG_COMMON_CLK_FSL_SAI) += clk-fsl-sai.o