aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch')
-rw-r--r--target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch b/target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch
new file mode 100644
index 0000000000..b1f88a6ac7
--- /dev/null
+++ b/target/linux/airoha/patches-5.15/0001-add-airoha-platform.patch
@@ -0,0 +1,35 @@
+diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
+index 66f5d6c3..05cd3385 100644
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -571,6 +571,18 @@ config ARCH_VIRT
+ select HAVE_ARM_ARCH_TIMER
+ select ARCH_SUPPORTS_BIG_ENDIAN
+
++config ARCH_AIROHA
++ bool "Airoha SoC Support"
++ depends on ARCH_MULTI_V7
++ select ARM_AMBA
++ select ARM_GIC
++ select ARM_GIC_V3
++ select ARM_PSCI
++ select HAVE_ARM_ARCH_TIMER
++ select COMMON_CLK
++ help
++ Support for Airoha EN7523 SoCs
++
+ #
+ # This is sorted alphabetically by mach-* pathname. However, plat-*
+ # Kconfigs may be included either alphabetically (according to the
+diff --git a/arch/arm/Makefile b/arch/arm/Makefile
+index fa45837b..c34f7463 100644
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
+@@ -156,6 +156,7 @@ textofs-$(CONFIG_ARCH_AXXIA) := 0x00308000
+ # Machine directory name. This list is sorted alphanumerically
+ # by CONFIG_* macro name.
+ machine-$(CONFIG_ARCH_ACTIONS) += actions
++machine-$(CONFIG_ARCH_AIROHA) += airoha
+ machine-$(CONFIG_ARCH_ALPINE) += alpine
+ machine-$(CONFIG_ARCH_ARTPEC) += artpec
+ machine-$(CONFIG_ARCH_ASPEED) += aspeed