aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.23/300-i2c_gpio_custom.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/patches-2.6.23/300-i2c_gpio_custom.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.23/300-i2c_gpio_custom.patch34
1 files changed, 0 insertions, 34 deletions
diff --git a/target/linux/adm5120/patches-2.6.23/300-i2c_gpio_custom.patch b/target/linux/adm5120/patches-2.6.23/300-i2c_gpio_custom.patch
deleted file mode 100644
index 800742b324..0000000000
--- a/target/linux/adm5120/patches-2.6.23/300-i2c_gpio_custom.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Index: linux-2.6.23.14/drivers/i2c/busses/Kconfig
-===================================================================
---- linux-2.6.23.14.orig/drivers/i2c/busses/Kconfig
-+++ linux-2.6.23.14/drivers/i2c/busses/Kconfig
-@@ -125,6 +125,17 @@ config I2C_GPIO
- This is a very simple bitbanging I2C driver utilizing the
- arch-neutral GPIO API to control the SCL and SDA lines.
-
-+config I2C_GPIO_CUSTOM
-+ tristate "Custom GPIO-based I2C driver"
-+ depends on GENERIC_GPIO
-+ select I2C_GPIO
-+ help
-+ This is an I2C driver to register 1 to 4 custom I2C buses using
-+ GPIO lines.
-+
-+ This support is also available as a module. If so, the module
-+ will be called i2c-gpio-custom.
-+
- config I2C_HYDRA
- tristate "CHRP Apple Hydra Mac I/O I2C interface"
- depends on PCI && PPC_CHRP && EXPERIMENTAL
-Index: linux-2.6.23.14/drivers/i2c/busses/Makefile
-===================================================================
---- linux-2.6.23.14.orig/drivers/i2c/busses/Makefile
-+++ linux-2.6.23.14/drivers/i2c/busses/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_I2C_AU1550) += i2c-au1550.o
- obj-$(CONFIG_I2C_BLACKFIN_TWI) += i2c-bfin-twi.o
- obj-$(CONFIG_I2C_ELEKTOR) += i2c-elektor.o
- obj-$(CONFIG_I2C_GPIO) += i2c-gpio.o
-+obj-$(CONFIG_I2C_GPIO_CUSTOM) += i2c-gpio-custom.o
- obj-$(CONFIG_I2C_HYDRA) += i2c-hydra.o
- obj-$(CONFIG_I2C_I801) += i2c-i801.o
- obj-$(CONFIG_I2C_I810) += i2c-i810.o