aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/config
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/config')
-rw-r--r--scripts/config/.gitignore7
-rw-r--r--scripts/config/Makefile5
2 files changed, 11 insertions, 1 deletions
diff --git a/scripts/config/.gitignore b/scripts/config/.gitignore
index b5bf92f66d..737c5b7953 100644
--- a/scripts/config/.gitignore
+++ b/scripts/config/.gitignore
@@ -12,3 +12,10 @@ mconf
nconf
qconf
gconf
+
+#
+# temporary files from older version. Should be removed
+#
+zconf.???.c
+zconf.hash.c
+.tmp_qtcheck
diff --git a/scripts/config/Makefile b/scripts/config/Makefile
index eb55b759a8..d98f15c393 100644
--- a/scripts/config/Makefile
+++ b/scripts/config/Makefile
@@ -7,7 +7,10 @@ all: conf mconf
clean:
rm -f *.o lxdialog/*.o *.moc $(clean-files) conf mconf qconf
-clean-files :=
+# This clean-files definition is here to ensure that temporary files from the
+# previous version are removed by make config-clean.
+# It should be removed or emptied when this Makefile get updated again.
+clean-files := zconf.tab.c zconf.lex.c zconf.hash.c .tmp_qtcheck
# ===========================================================================
# Variables needed by the upstream Makefile