aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/config
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2020-04-19 20:12:52 -0300
committerPetr Štetiar <ynezz@true.cz>2020-05-20 17:03:45 +0200
commit80b350f528644c269c8630e41a4a992734356bb3 (patch)
tree6e81206660a830f92c1727f7066b45cec7eba2b0 /scripts/config
parentdb6c1214e0fbf9b9268f2ea2c90e7d6da4f1a577 (diff)
downloadupstream-80b350f528644c269c8630e41a4a992734356bb3.tar.gz
upstream-80b350f528644c269c8630e41a4a992734356bb3.tar.bz2
upstream-80b350f528644c269c8630e41a4a992734356bb3.zip
build: have config-clean deal with old temp files
This is a temporary commit to have 'make config-clean' remove temporary files from the previous scripts/config version. The .gitignore file is updated to deal with the old files as well. Cc: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'scripts/config')
-rw-r--r--scripts/config/.gitignore7
-rw-r--r--scripts/config/Makefile5
2 files changed, 11 insertions, 1 deletions
diff --git a/scripts/config/.gitignore b/scripts/config/.gitignore
index b5bf92f66d..737c5b7953 100644
--- a/scripts/config/.gitignore
+++ b/scripts/config/.gitignore
@@ -12,3 +12,10 @@ mconf
nconf
qconf
gconf
+
+#
+# temporary files from older version. Should be removed
+#
+zconf.???.c
+zconf.hash.c
+.tmp_qtcheck
diff --git a/scripts/config/Makefile b/scripts/config/Makefile
index eb55b759a8..d98f15c393 100644
--- a/scripts/config/Makefile
+++ b/scripts/config/Makefile
@@ -7,7 +7,10 @@ all: conf mconf
clean:
rm -f *.o lxdialog/*.o *.moc $(clean-files) conf mconf qconf
-clean-files :=
+# This clean-files definition is here to ensure that temporary files from the
+# previous version are removed by make config-clean.
+# It should be removed or emptied when this Makefile get updated again.
+clean-files := zconf.tab.c zconf.lex.c zconf.hash.c .tmp_qtcheck
# ===========================================================================
# Variables needed by the upstream Makefile