aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/config/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/config/Makefile')
-rw-r--r--scripts/config/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/scripts/config/Makefile b/scripts/config/Makefile
index d98f15c393..3082a65ceb 100644
--- a/scripts/config/Makefile
+++ b/scripts/config/Makefile
@@ -5,7 +5,7 @@
.PHONY: clean all
all: conf mconf
clean:
- rm -f *.o lxdialog/*.o *.moc $(clean-files) conf mconf qconf
+ rm -f *.o lxdialog/*.o *.moc $(clean-files) conf mconf qconf nconf
# This clean-files definition is here to ensure that temporary files from the
# previous version are removed by make config-clean.
@@ -52,6 +52,16 @@ HOSTCFLAGS_parser.tab.o := -I $(srctree)/$(src)
hostprogs-y += conf
conf-objs := conf.o $(common-objs)
+# nconf: Used for the nconfig target based on ncurses
+hostprogs-y += nconf
+nconf-objs := nconf.o nconf.gui.o $(common-objs)
+
+HOSTLDLIBS_nconf = $(shell . $(obj)/nconf-cfg && echo $$libs)
+HOSTCFLAGS_nconf.o = $(shell . $(obj)/nconf-cfg && echo $$cflags)
+HOSTCFLAGS_nconf.gui.o = $(shell . $(obj)/nconf-cfg && echo $$cflags)
+
+$(obj)/nconf.o $(obj)/nconf.gui.o: $(obj)/nconf-cfg
+
# mconf: Used for the menuconfig target based on lxdialog
hostprogs-y += mconf
lxdialog := $(addprefix lxdialog/, \
@@ -123,5 +133,8 @@ conf: $(conf-objs)
mconf: mconf-cfg $(mconf-objs)
$(CC) -o $@ $(filter-out mconf-cfg,$^) $(HOSTLDLIBS_mconf)
+nconf: nconf-cfg $(nconf-objs)
+ $(CC) -o $@ $(filter-out nconf-cfg,$^) $(HOSTLDLIBS_nconf)
+
qconf: qconf-cfg $(qconf-cxxobjs) $(qconf-objs)
$(CXX) -o $@ $(filter-out qconf-cfg,$^) $(HOSTLDLIBS_qconf)