aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/nftables/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/package/network/utils/nftables/Makefile b/package/network/utils/nftables/Makefile
index f3bdc5caee..d1e995116d 100644
--- a/package/network/utils/nftables/Makefile
+++ b/package/network/utils/nftables/Makefile
@@ -34,10 +34,21 @@ define Package/nftables
CATEGORY:=Network
SUBMENU:=Firewall
TITLE:=nftables packet filtering userspace utility
- DEPENDS:=+kmod-nft-core +libnftnl
+ DEPENDS:=+kmod-nft-core +libnftnl +PACKAGE_NFT_WITH_JSON:jansson
URL:=http://netfilter.org/projects/nftables/
endef
+define Package/nftables/config
+ config PACKAGE_NFT_WITH_JSON
+ bool "Build nftables with json support"
+ depends on PACKAGE_nftables
+ default n
+endef
+
+ifeq ($(CONFIG_PACKAGE_NFT_WITH_JSON),y)
+CONFIGURE_ARGS += --with-json
+endif
+
define Package/nftables/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/nft $(1)/usr/sbin/