aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/network/ipv6/map/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/package/network/ipv6/map/Makefile b/package/network/ipv6/map/Makefile
index 10dbe97b48..5a18c7b01f 100644
--- a/package/network/ipv6/map/Makefile
+++ b/package/network/ipv6/map/Makefile
@@ -18,16 +18,17 @@ include $(INCLUDE_DIR)/cmake.mk
define Package/map
SECTION:=net
CATEGORY:=Network
- DEPENDS:=@IPV6 +kmod-ip6-tunnel +libubox +libubus +iptables-mod-conntrack-extra
- TITLE:=MAP-E and Lightweight 4over6 configuration support
+ DEPENDS:=@IPV6 +kmod-ip6-tunnel +libubox +libubus +iptables-mod-conntrack-extra +kmod-nat46
+ TITLE:=MAP-E/MAP-T and Lightweight 4over6 configuration support
MAINTAINER:=Hans Dedecker <dedeckeh@gmail.com>
+ PROVIDES:=map-t
endef
define Package/map/description
- Provides support for MAP-E (draft-ietf-softwire-map) and
- Lightweight 4over6 (draft-ietf-softwire-lw4over6) in /etc/config/network.
- Refer to http://wiki.openwrt.org/doc/uci/network for
- configuration details.
+ Provides support for MAP-E (RFC7597), MAP-T (RFC7599) and
+ Lightweight 4over6 (RFC7596) in /etc/config/network.
+ MAP combines address and port translation with the tunneling
+ of IPv4 packets over an IPv6 network
endef
define Package/map/install