aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/crypto.mk15
1 files changed, 1 insertions, 14 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index edce712c56..f07676d6b7 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -600,7 +600,7 @@ $(eval $(call KernelPackage,crypto-lib-poly1305))
define KernelPackage/crypto-manager
TITLE:=CryptoAPI algorithm manager
- DEPENDS:=+kmod-crypto-aead +kmod-crypto-hash +kmod-crypto-pcompress
+ DEPENDS:=+kmod-crypto-aead +kmod-crypto-hash
KCONFIG:= \
CONFIG_CRYPTO_MANAGER \
CONFIG_CRYPTO_MANAGER2
@@ -770,19 +770,6 @@ endef
$(eval $(call KernelPackage,crypto-pcbc))
-define KernelPackage/crypto-pcompress
- TITLE:=CryptoAPI Partial (de)compression operations
- KCONFIG:= \
- CONFIG_CRYPTO_PCOMP=y \
- CONFIG_CRYPTO_PCOMP2
- FILES:=$(LINUX_DIR)/crypto/pcompress.ko
- AUTOLOAD:=$(call AutoLoad,09,pcompress)
- $(call AddDepends/crypto)
-endef
-
-$(eval $(call KernelPackage,crypto-pcompress))
-
-
define KernelPackage/crypto-rsa
TITLE:=RSA algorithm
DEPENDS:=+kmod-crypto-manager +kmod-asn1-decoder