aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/network/config/gre/Makefile2
-rwxr-xr-xpackage/network/config/gre/files/gre.sh11
2 files changed, 11 insertions, 2 deletions
diff --git a/package/network/config/gre/Makefile b/package/network/config/gre/Makefile
index 90f92d4da7..9193f5c9fb 100644
--- a/package/network/config/gre/Makefile
+++ b/package/network/config/gre/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gre
PKG_VERSION:=1
-PKG_RELEASE:=6
+PKG_RELEASE:=7
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/gre/files/gre.sh b/package/network/config/gre/files/gre.sh
index cd327ea2da..a6b4ba85f6 100755
--- a/package/network/config/gre/files/gre.sh
+++ b/package/network/config/gre/files/gre.sh
@@ -31,7 +31,16 @@ gre_generic_setup() {
json_add_string local "$local"
json_add_string remote "$remote"
[ -n "$tunlink" ] && json_add_string link "$tunlink"
- json_add_string info "${ikey:-0},${okey:-0},${icsum:-0},${ocsum:-0},${iseqno:-0},${oseqno:-0}"
+
+ json_add_object 'data'
+ [ -n "$ikey" ] && json_add_int ikey "$ikey"
+ [ -n "$okey" ] && json_add_int okey "$okey"
+ [ -n "$icsum" ] && json_add_boolean icsum "$icsum"
+ [ -n "$ocsum" ] && json_add_boolean ocsum "$ocsum"
+ [ -n "$iseqno" ] && json_add_boolean iseqno "$iseqno"
+ [ -n "$oseqno" ] && json_add_boolean oseqno "$oseqno"
+ json_close_object
+
proto_close_tunnel
proto_add_data