aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux/patches/110-meson-fix-when-HAVE_CLOCK_GETTIME-is-set.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/util-linux/patches/110-meson-fix-when-HAVE_CLOCK_GETTIME-is-set.patch')
-rw-r--r--package/utils/util-linux/patches/110-meson-fix-when-HAVE_CLOCK_GETTIME-is-set.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/utils/util-linux/patches/110-meson-fix-when-HAVE_CLOCK_GETTIME-is-set.patch b/package/utils/util-linux/patches/110-meson-fix-when-HAVE_CLOCK_GETTIME-is-set.patch
new file mode 100644
index 0000000000..bba8baf5ab
--- /dev/null
+++ b/package/utils/util-linux/patches/110-meson-fix-when-HAVE_CLOCK_GETTIME-is-set.patch
@@ -0,0 +1,21 @@
+From e51565b653cf09985df57cb7254b16d5af5df223 Mon Sep 17 00:00:00 2001
+From: Nicolas Caramelli <caramelli.devel@gmail.com>
+Date: Fri, 29 Apr 2022 18:16:36 +0200
+Subject: [PATCH] meson: fix when HAVE_CLOCK_GETTIME is set
+
+Signed-off-by: Nicolas Caramelli <caramelli.devel@gmail.com>
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/meson.build
++++ b/meson.build
+@@ -602,7 +602,7 @@ if not have
+ have = cc.has_function('clock_gettime',
+ dependencies : realtime_libs)
+ endif
+-conf.set('HAVE_CLOCK_GETTIME', have_dirfd ? 1 : false)
++conf.set('HAVE_CLOCK_GETTIME', have ? 1 : false)
+
+ thread_libs = dependency('threads')
+