aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux/patches/080-meson-fix-tzname-check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/util-linux/patches/080-meson-fix-tzname-check.patch')
-rw-r--r--package/utils/util-linux/patches/080-meson-fix-tzname-check.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/package/utils/util-linux/patches/080-meson-fix-tzname-check.patch b/package/utils/util-linux/patches/080-meson-fix-tzname-check.patch
new file mode 100644
index 0000000000..f5d53c4d36
--- /dev/null
+++ b/package/utils/util-linux/patches/080-meson-fix-tzname-check.patch
@@ -0,0 +1,23 @@
+From 9a6b2618b46a859388139d1eb18f876886786659 Mon Sep 17 00:00:00 2001
+From: Rosen Penev <rosenp@gmail.com>
+Date: Fri, 29 Apr 2022 19:00:53 -0700
+Subject: [PATCH] meson: fix tzname check
+
+tzname is not a type but a variable. sizeof only works on types.
+
+Signed-off-by: Rosen Penev <rosenp@gmail.com>
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/meson.build
++++ b/meson.build
+@@ -565,7 +565,7 @@ have = cc.has_member('struct tm', 'tm_zo
+ prefix : '#include <time.h>')
+ conf.set('HAVE_STRUCT_TM_TM_ZONE', have ? 1 : false)
+
+-have = cc.sizeof('tzname', prefix : '#include <time.h>') > 0
++have = cc.has_header_symbol('time.h', 'tzname')
+ conf.set('HAVE_DECL_TZNAME', have ? 1 : false)
+
+ code = '''