aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux/patches/020-meson-fix-compilation-without-systemd.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/util-linux/patches/020-meson-fix-compilation-without-systemd.patch')
-rw-r--r--package/utils/util-linux/patches/020-meson-fix-compilation-without-systemd.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/utils/util-linux/patches/020-meson-fix-compilation-without-systemd.patch b/package/utils/util-linux/patches/020-meson-fix-compilation-without-systemd.patch
new file mode 100644
index 0000000000..aa209994ec
--- /dev/null
+++ b/package/utils/util-linux/patches/020-meson-fix-compilation-without-systemd.patch
@@ -0,0 +1,22 @@
+From 38b15ca2dc4ca32bbe4a2449e1c7b645e4577840 Mon Sep 17 00:00:00 2001
+From: Rosen Penev <rosenp@gmail.com>
+Date: Fri, 29 Apr 2022 16:53:43 -0700
+Subject: [PATCH 1/7] meson: fix compilation without systemd
+
+systemdsystemunitdir is used elsewhere.
+
+Signed-off-by: Rosen Penev <rosenp@gmail.com>
+---
+ meson.build | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/meson.build
++++ b/meson.build
+@@ -720,6 +720,7 @@ if fs_search_path_extra != ''
+ endif
+ conf.set_quoted('FS_SEARCH_PATH', fs_search_path)
+
++systemdsystemunitdir = ''
+ if systemd.found()
+ systemdsystemunitdir = systemd.get_pkgconfig_variable('systemdsystemunitdir')
+ endif