aboutsummaryrefslogtreecommitdiffstats
path: root/package/soloscli/patches
diff options
context:
space:
mode:
Diffstat (limited to 'package/soloscli/patches')
-rw-r--r--package/soloscli/patches/000-Makefile.patch21
-rw-r--r--package/soloscli/patches/001-newline.patch11
2 files changed, 32 insertions, 0 deletions
diff --git a/package/soloscli/patches/000-Makefile.patch b/package/soloscli/patches/000-Makefile.patch
new file mode 100644
index 0000000000..914d6d886b
--- /dev/null
+++ b/package/soloscli/patches/000-Makefile.patch
@@ -0,0 +1,21 @@
+--- a/Makefile 2010-06-14 14:17:11.000000000 +1000
++++ b/Makefile 2010-06-14 14:17:54.000000000 +1000
+@@ -13,6 +13,11 @@
+ KDIR ?= /lib/modules/$(shell uname -r)/build
+ PWD := $(shell pwd)
+
++soloscli/soloscli:
++ $(MAKE) -C soloscli
++
++install:
++
+ default:
+ $(MAKE) -C $(KDIR) M=$(PWD) modules
+
+@@ -20,5 +25,6 @@
+ rm -f *.o *.ko *.mod.c .*.cmd
+ rm -rf .tmp_versions
+ rm -f Module.symvers
++ $(MAKE) -C soloscli clean
+
+ endif
diff --git a/package/soloscli/patches/001-newline.patch b/package/soloscli/patches/001-newline.patch
new file mode 100644
index 0000000000..69cd5b28a6
--- /dev/null
+++ b/package/soloscli/patches/001-newline.patch
@@ -0,0 +1,11 @@
+--- a/soloscli/soloscli.c
++++ b/soloscli/soloscli.c
+@@ -238,7 +238,7 @@
+ }
+ if (strcmp(buf,pid) == 0) {
+ /* printf("Sequence matches.\n"); */
+- printf("%s",bufp);
++ printf("%s\n",bufp);
+ } else {
+ printf("Sequence incorrect.\n");
+ buf[i] = '\n';