aboutsummaryrefslogtreecommitdiffstats
path: root/package/pjsip/patches/000-aconf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/pjsip/patches/000-aconf.patch')
-rw-r--r--package/pjsip/patches/000-aconf.patch11
1 files changed, 7 insertions, 4 deletions
diff --git a/package/pjsip/patches/000-aconf.patch b/package/pjsip/patches/000-aconf.patch
index 96c519aea0..46e4aad4ac 100644
--- a/package/pjsip/patches/000-aconf.patch
+++ b/package/pjsip/patches/000-aconf.patch
@@ -1,15 +1,18 @@
--- a/aconfigure.ac
+++ b/aconfigure.ac
-@@ -48,7 +48,7 @@
+@@ -48,9 +48,9 @@ if test -z "$CROSS_COMPILE"; then
CROSS_COMPILE=`echo ${CC} | sed 's/gcc//'`
fi
-if test "$AR" = ""; then AR="${CROSS_COMPILE}ar rv"; fi
+AR="${CROSS_COMPILE}ar rv"
AC_SUBST(AR)
- if test "$LD" = ""; then LD="$CC"; fi
+-if test "$LD" = ""; then LD="$CC"; fi
++LD="${CROSS_COMPILE}gcc"
AC_SUBST(LD)
-@@ -590,6 +590,15 @@
+ if test "$LDOUT" = ""; then LDOUT="-o"; fi
+ AC_SUBST(LDOUT)
+@@ -597,6 +597,15 @@ AC_ARG_ENABLE(ext_sound,
AC_MSG_RESULT([Checking if external sound is set... yes])
fi]
)
@@ -27,7 +30,7 @@
AC_SUBST(ac_no_small_filter)
--- a/pjmedia/build/os-auto.mak.in
+++ b/pjmedia/build/os-auto.mak.in
-@@ -118,4 +118,11 @@
+@@ -118,4 +118,11 @@ ifeq ($(AC_PJMEDIA_SND),external)
export CFLAGS += -DPJMEDIA_AUDIO_DEV_HAS_PORTAUDIO=0 -DPJMEDIA_AUDIO_DEV_HAS_WMME=0
endif