aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/lldpd/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index 02f656a341..3605ed25f9 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -85,6 +85,10 @@ define Package/lldpd/conffiles
/etc/config/lldpd
endef
+CONFIGURE_VARS += \
+ $(if $(CONFIG_USE_GLIBC),,libbsd_CFLAGS=-ldo-not-link-bsd) \
+ $(if $(CONFIG_USE_GLIBC),,libbsd_LDFLAGS=-ldo-not-link-bsd)
+
CONFIGURE_ARGS += \
$(if $(CONFIG_LLDPD_WITH_PRIVSEP), \
--with-privsep-user=lldp \