aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
Diffstat (limited to 'package/network')
-rw-r--r--package/network/services/uhttpd/Makefile17
-rw-r--r--package/network/services/uhttpd/files/uhttpd.config4
2 files changed, 17 insertions, 4 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 39e8894ebc..3d483b692d 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(LEDE_GIT)/project/uhttpd.git
@@ -46,9 +46,12 @@ define Package/uhttpd/config
config PACKAGE_uhttpd_debug
bool "Build with debug messages"
default n
+ config uhttpd_lua
+ depends on PACKAGE_uhttpd-mod-lua
+ bool "Enable Integrated Lua interpreter"
+ default y
endef
-
define Package/uhttpd-mod-lua
$(Package/uhttpd/default)
TITLE+= (Lua plugin)
@@ -106,6 +109,16 @@ define Package/uhttpd-mod-ubus/install
$(INSTALL_DATA) ./files/ubus.default $(1)/etc/uci-defaults/00_uhttpd_ubus
endef
+define Package/uhttpd-mod-lua/postinst
+ $(if $(CONFIG_uhttpd_lua),
+ #!/bin/sh
+ if [ -f $${IPKG_INSTROOT}/www/index.html ]
+ then
+ sed -e 's:/cgi-bin::g' -i $${IPKG_INSTROOT}/www/index.html
+ fi
+ ,)
+endef
+
$(eval $(call BuildPackage,uhttpd))
$(eval $(call BuildPackage,uhttpd-mod-lua))
diff --git a/package/network/services/uhttpd/files/uhttpd.config b/package/network/services/uhttpd/files/uhttpd.config
index 89f99aaeea..563c079a1a 100644
--- a/package/network/services/uhttpd/files/uhttpd.config
+++ b/package/network/services/uhttpd/files/uhttpd.config
@@ -51,8 +51,8 @@ config uhttpd main
# Lua url prefix and handler script.
# Lua support is disabled if no prefix given.
-# option lua_prefix /luci
-# option lua_handler /usr/lib/lua/luci/sgi/uhttpd.lua
+ option lua_prefix /luci
+ option lua_handler /usr/lib/lua/luci/sgi/uhttpd.lua
# Specify the ubus-rpc prefix and socket path.
# option ubus_prefix /ubus