aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/iproute2/patches/950-add-cake-to-tc.patch')
-rw-r--r--package/network/utils/iproute2/patches/950-add-cake-to-tc.patch11
1 files changed, 5 insertions, 6 deletions
diff --git a/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch b/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
index 5e91cd7ed1..5edb71ddc9 100644
--- a/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
+++ b/package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
@@ -1,10 +1,9 @@
--- a/include/uapi/linux/pkt_sched.h
+++ b/include/uapi/linux/pkt_sched.h
-@@ -872,4 +872,63 @@ struct tc_pie_xstats {
- __u32 maxq; /* maximum queue size */
- __u32 ecn_mark; /* packets marked with ecn*/
- };
-+
+@@ -934,4 +934,62 @@ enum {
+
+ #define TCA_CBS_MAX (__TCA_CBS_MAX - 1)
+
+/* CAKE */
+enum {
+ TCA_CAKE_UNSPEC,
@@ -66,7 +65,7 @@
#endif
--- a/tc/Makefile
+++ b/tc/Makefile
-@@ -65,6 +65,7 @@ TCMODULES += q_codel.o
+@@ -66,6 +66,7 @@ TCMODULES += q_codel.o
TCMODULES += q_fq_codel.o
TCMODULES += q_fq.o
TCMODULES += q_pie.o