aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/ppp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/services/ppp/Makefile')
-rw-r--r--package/network/services/ppp/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/network/services/ppp/Makefile b/package/network/services/ppp/Makefile
index 48f2091a1f..80d5e46c34 100644
--- a/package/network/services/ppp/Makefile
+++ b/package/network/services/ppp/Makefile
@@ -26,7 +26,7 @@ PKG_VERSION:=$(PKG_RELEASE_VERSION).git-$(PKG_SOURCE_DATE)
PKG_BUILD_DEPENDS:=libpcap
PKG_ASLR_PIE_REGULAR:=1
-PKG_BUILD_FLAGS:=gc-sections
+PKG_BUILD_FLAGS:=gc-sections lto
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
@@ -193,9 +193,6 @@ $(call Build/Configure/Default,, \
$(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
endef
-TARGET_CFLAGS += -flto
-TARGET_LDFLAGS += -flto -fuse-linker-plugin
-
MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \
PRECOMPILED_FILTER=1 \
STAGING_DIR="$(STAGING_DIR)"