aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/lldpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/services/lldpd/Makefile')
-rw-r--r--package/network/services/lldpd/Makefile33
1 files changed, 29 insertions, 4 deletions
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index 3a2e41122d..cffae63dfd 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lldpd
-PKG_VERSION:=0.7.7
+PKG_VERSION:=0.7.10
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://media.luffy.cx/files/lldpd
-PKG_MD5SUM:=9031734c69940dd79a0a175123275f83
+PKG_MD5SUM:=508f2e76703abf8420d9223aae3db548
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
PKG_LICENSE:=ISC
@@ -31,8 +31,13 @@ define Package/lldpd
SUBMENU:=Routing and Redirection
TITLE:=Link Layer Discovery Protocol daemon
URL:=https://github.com/vincentbernat/lldpd/wiki
- DEPENDS:=+libevent2 +USE_EGLIBC:libbsd
+ DEPENDS:=+libevent2 +USE_EGLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
USERID:=lldp=121:lldp=129
+ MENU:=1
+endef
+
+define Package/lldpd/config
+source "$(SOURCE)/Config.in"
endef
define Package/lldpd/description
@@ -46,12 +51,25 @@ endef
define Package/lldpd/install
$(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_DIR) $(1)/etc/lldpd.d
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DIR) $(1)/usr/lib $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/lldp{cli,ctl,d} $(1)/usr/sbin/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
$(INSTALL_BIN) ./files/lldpd.init $(1)/etc/init.d/lldpd
$(INSTALL_DATA) ./files/lldpd.config $(1)/etc/config/lldpd
+ifneq ($(CONFIG_LLDPD_WITH_CDP),y)
+ sed -i -e '/cdp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
+ifneq ($(CONFIG_LLDPD_WITH_FDP),y)
+ sed -i -e '/fdp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
+ifneq ($(CONFIG_LLDPD_WITH_EDP),y)
+ sed -i -e '/edp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
+ifneq ($(CONFIG_LLDPD_WITH_SONMP),y)
+ sed -i -e '/sonmp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
endef
define Package/lldpd/conffiles
@@ -62,6 +80,13 @@ CONFIGURE_ARGS += \
--with-privsep-user=lldp \
--with-privsep-group=lldp \
--with-privsep-chroot=/var/run/lldp \
- --with-readline=no
+ --with-readline=no \
+ --with-embedded-libevent=no \
+ $(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
+ $(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
+ $(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \
+ $(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
+ $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c)
+
$(eval $(call BuildPackage,lldpd))