aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile18
1 files changed, 0 insertions, 18 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index f340cb1ebb..c03ec6bdc4 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -68,9 +68,6 @@ CONFIG_VARIANT:=$(LOCAL_VARIANT)
ifeq ($(LOCAL_VARIANT),mesh)
CONFIG_VARIANT:=full
endif
-ifeq ($(LOCAL_VARIANT),hs20)
- CONFIG_VARIANT:=full
-endif
include $(INCLUDE_DIR)/package.mk
@@ -111,10 +108,6 @@ ifeq ($(SSL_VARIANT),openssl)
ifeq ($(LOCAL_VARIANT),full)
DRIVER_MAKEOPTS += CONFIG_OWE=y CONFIG_SUITEB192=y CONFIG_AP=y CONFIG_MESH=y
endif
- ifeq ($(LOCAL_VARIANT),hs20)
- DRIVER_MAKEOPTS += CONFIG_OWE=y CONFIG_SUITEB192=y CONFIG_AP=y CONFIG_MESH=y CONFIG_DPP=y CONFIG_HS20=y CONFIG_INTERWORKING=y
- endif
-
endif
ifeq ($(SSL_VARIANT),wolfssl)
@@ -175,15 +168,6 @@ endef
Package/hostapd-openssl/description = $(Package/hostapd/description)
-define Package/hostapd-hs20
-$(call Package/hostapd/Default,$(1))
- TITLE+= (OpenSSL with Hotspot 2.0)
- VARIANT:=hs20-openssl
- DEPENDS+=+libopenssl
-endef
-
-Package/hostapd-hs20/description = $(Package/hostapd/description)
-
define Package/hostapd-wolfssl
$(call Package/hostapd/Default,$(1))
TITLE+= (wolfSSL full)
@@ -608,7 +592,6 @@ define Package/hostapd/install
endef
Package/hostapd-basic/install = $(Package/hostapd/install)
Package/hostapd-basic-openssl/install = $(Package/hostapd/install)
-Package/hostapd-hs20/install = $(Package/hostapd/install)
Package/hostapd-mini/install = $(Package/hostapd/install)
Package/hostapd-openssl/install = $(Package/hostapd/install)
Package/hostapd-wolfssl/install = $(Package/hostapd/install)
@@ -679,7 +662,6 @@ endif
$(eval $(call BuildPackage,hostapd))
$(eval $(call BuildPackage,hostapd-basic))
$(eval $(call BuildPackage,hostapd-basic-openssl))
-$(eval $(call BuildPackage,hostapd-hs20))
$(eval $(call BuildPackage,hostapd-mini))
$(eval $(call BuildPackage,hostapd-openssl))
$(eval $(call BuildPackage,hostapd-wolfssl))