aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/netifd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/config/netifd/Makefile')
-rw-r--r--package/network/config/netifd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index e4720aa821..7d916b6939 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
@@ -27,6 +27,7 @@ endef
define Package/netifd/conffiles
/etc/udhcpc.user
+/etc/udhcpc.user.d/
endef
TARGET_CFLAGS += \
@@ -44,6 +45,7 @@ define Package/netifd/install
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/netifd $(1)/sbin/
$(CP) ./files/* $(1)/
+ $(INSTALL_DIR) $(1)/etc/udhcpc.user.d/
$(CP) $(PKG_BUILD_DIR)/scripts/* $(1)/lib/netifd/
endef