aboutsummaryrefslogtreecommitdiffstats
path: root/package/ltq-dsl-app/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/ltq-dsl-app/Makefile')
-rw-r--r--package/ltq-dsl-app/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/ltq-dsl-app/Makefile b/package/ltq-dsl-app/Makefile
index fb3e4ac644..981a6a7961 100644
--- a/package/ltq-dsl-app/Makefile
+++ b/package/ltq-dsl-app/Makefile
@@ -22,12 +22,15 @@ PKG_CONFIG_DEPENDS:=\
include $(INCLUDE_DIR)/package.mk
+PKG_BUILD_DEPENDS:=TARGET_lantiq_danube:kmod-ltq-dsl-danube TARGET_lantiq_ar9:kmod-ltq-dsl-ar9 \
+ TARGET_lantiq_vr9:kmod-ltq-dsl-vr9 TARGET_lantiq_ase:kmod-ltq-dsl-ase
+
define Package/ltq-dsl-app
SECTION:=net
CATEGORY:=Network
TITLE:=Lantiq DSL userland tool
URL:=http://www.lantiq.com/
- DEPENDS:=@TARGET_lantiq_danube +kmod-ltq-dsl +libpthread
+ DEPENDS:=@TARGET_lantiq&&!(TARGET_lantiq_falcon||TARGET_lantiq_falcon_stable) +libpthread
MAINTAINER:=John Crispin <blogic@openwrt.org>
MENU:=1
endef