aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libiconv-full/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/package/libs/libiconv-full/Makefile b/package/libs/libiconv-full/Makefile
index 85495fbf91..e4f925a1ae 100644
--- a/package/libs/libiconv-full/Makefile
+++ b/package/libs/libiconv-full/Makefile
@@ -21,6 +21,8 @@ PKG_LICENSE:=LGPL-2.1-or-later
PKG_LICENSE_FILES:=COPYING.LIB
PKG_FIXUP:=patch-libtool
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
@@ -53,21 +55,12 @@ define Package/iconv
TITLE+= utility
endef
-TARGET_CFLAGS += $(FPIC) -DUSE_DOS -std=gnu89
-
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--disable-rpath \
--enable-relocatable
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CC="$(TARGET_CC)" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- install
-endef
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib/libiconv-full/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/iconv.h $(1)/usr/lib/libiconv-full/include/