aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch')
-rw-r--r--package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch100
1 files changed, 100 insertions, 0 deletions
diff --git a/package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch b/package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch
new file mode 100644
index 0000000000..68f317b24b
--- /dev/null
+++ b/package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch
@@ -0,0 +1,100 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8e75f66..24d7329 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -95,34 +95,67 @@ set(ZLIB_PUBLIC_HDRS
+ ${CMAKE_CURRENT_BINARY_DIR}/zconf.h
+ zlib.h
+ )
+-set(ZLIB_PRIVATE_HDRS
+- crc32.h
+- deflate.h
+- gzguts.h
+- inffast.h
+- inffixed.h
+- inflate.h
+- inftrees.h
+- trees.h
+- zutil.h
+-)
+-set(ZLIB_SRCS
+- adler32.c
+- compress.c
+- crc32.c
+- deflate.c
+- gzclose.c
+- gzlib.c
+- gzread.c
+- gzwrite.c
+- inflate.c
+- infback.c
+- inftrees.c
+- inffast.c
+- trees.c
+- uncompr.c
+- zutil.c
+-)
++
++if(ARMv8)
++ set(ZLIB_PRIVATE_HDRS
++ crc32.h
++ deflate.h
++ gzguts.h
++ inffast.h
++ inffixed.h
++ inflate.h
++ inftrees.h
++ trees.h
++ zutil.h
++ contrib/arm/chunkcopy.h
++ )
++ set(ZLIB_SRCS
++ adler32.c
++ compress.c
++ crc32.c
++ deflate.c
++ gzclose.c
++ gzlib.c
++ gzread.c
++ gzwrite.c
++ infback.c
++ inftrees.c
++ contrib/arm/inflate.c
++ contrib/arm/inffast.c
++ trees.c
++ uncompr.c
++ zutil.c
++ )
++ else()
++ set(ZLIB_PRIVATE_HDRS
++ crc32.h
++ deflate.h
++ gzguts.h
++ inffast.h
++ inffixed.h
++ inflate.h
++ inftrees.h
++ trees.h
++ zutil.h
++ )
++ set(ZLIB_SRCS
++ adler32.c
++ compress.c
++ crc32.c
++ deflate.c
++ gzclose.c
++ gzlib.c
++ gzread.c
++ gzwrite.c
++ inflate.c
++ infback.c
++ inftrees.c
++ inffast.c
++ trees.c
++ uncompr.c
++ zutil.c
++ )
++endif()
+
+ if(NOT MINGW)
+ set(ZLIB_DLL_SRCS