aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libunwind/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/libunwind/Makefile')
-rw-r--r--package/libs/libunwind/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/package/libs/libunwind/Makefile b/package/libs/libunwind/Makefile
index 7d51f7487d..ba22664b28 100644
--- a/package/libs/libunwind/Makefile
+++ b/package/libs/libunwind/Makefile
@@ -1,5 +1,6 @@
#
# Copyright (C) 2008-2013 OpenWrt.org
+# Copyright (C) 2017 Yousong Zhou <yszhou4tech@gmail.com>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libunwind
-PKG_VERSION:=1.1
+PKG_VERSION:=1.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
-PKG_HASH:=9dfe0fcae2a866de9d3942c66995e4b460230446887dbdab302d41a8aee8d09a
+PKG_HASH:=1de38ffbdc88bd694d10081865871cd2bfbb02ad8ef9e1606aee18d65532b992
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@@ -36,7 +37,10 @@ define Package/libunwind/description
Libunwind defines a portable and efficient C programming interface (API) to determine the call-chain of a program.
endef
-CONFIGURE_ARGS += --enable-minidebuginfo=no
+CONFIGURE_ARGS += \
+ --disable-documentation \
+ --enable-minidebuginfo=no \
+
define Package/libunwind/install
$(INSTALL_DIR) $(1)/usr/lib