aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libnl
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/libnl')
-rw-r--r--package/libs/libnl/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/libs/libnl/Makefile b/package/libs/libnl/Makefile
index 71b043a9e5..56549dcc0a 100644
--- a/package/libs/libnl/Makefile
+++ b/package/libs/libnl/Makefile
@@ -20,6 +20,8 @@ PKG_CPE_ID:=cpe:/a:libnl_project:libnl
PKG_INSTALL:=1
PKG_FIXUP:=autoreconf
+PKG_BUILD_FLAGS:=gc-sections
+
include $(INCLUDE_DIR)/package.mk
define Package/libnl/default
@@ -80,7 +82,7 @@ define Package/libnl/description
message construction and parsing, object caching system, etc.
endef
-TARGET_CFLAGS += -ffunction-sections -fdata-sections $(FPIC)
+TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--disable-debug