aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libjson-c/patches/000-libm.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs/libjson-c/patches/000-libm.patch')
-rw-r--r--package/libs/libjson-c/patches/000-libm.patch23
1 files changed, 4 insertions, 19 deletions
diff --git a/package/libs/libjson-c/patches/000-libm.patch b/package/libs/libjson-c/patches/000-libm.patch
index de98e35d43..35ffec8724 100644
--- a/package/libs/libjson-c/patches/000-libm.patch
+++ b/package/libs/libjson-c/patches/000-libm.patch
@@ -1,18 +1,3 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -76,12 +76,6 @@ AC_FUNC_VPRINTF
- AC_FUNC_MEMCMP
- AC_CHECK_FUNCS([realloc])
- AC_CHECK_FUNCS(strcasecmp strdup strerror snprintf vsnprintf vasprintf open vsyslog strncasecmp setlocale)
--AC_CHECK_DECLS([INFINITY], [], [], [[#include <math.h>]])
--AC_CHECK_DECLS([nan], [], [], [[#include <math.h>]])
--AC_CHECK_DECLS([isnan], [], [], [[#include <math.h>]])
--AC_CHECK_DECLS([isinf], [], [], [[#include <math.h>]])
--AC_CHECK_DECLS([_isnan], [], [], [[#include <float.h>]])
--AC_CHECK_DECLS([_finite], [], [], [[#include <float.h>]])
- AC_MSG_CHECKING(for GCC atomic builtins)
- AC_LINK_IFELSE(
- [
--- a/math_compat.h
+++ b/math_compat.h
@@ -6,31 +6,9 @@
@@ -22,17 +7,17 @@
-/* Define isnan, isinf, infinity and nan on Windows/MSVC */
-
-#ifndef HAVE_DECL_ISNAN
--# ifdef HAVE_DECL__ISNAN
+-#ifdef HAVE_DECL__ISNAN
-#include <float.h>
-#define isnan(x) _isnan(x)
--# endif
+-#endif
-#endif
-
-#ifndef HAVE_DECL_ISINF
--# ifdef HAVE_DECL__FINITE
+-#ifdef HAVE_DECL__FINITE
-#include <float.h>
-#define isinf(x) (!_finite(x))
--# endif
+-#endif
-#endif
-
-#ifndef HAVE_DECL_INFINITY