aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/sound.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 4e1a656dd2..bed2e3c802 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -42,10 +42,10 @@ endif
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.12.0)),1)
SOUNDCORE_LOAD += \
- snd-pcm-dmaengine
+ $(if $(CONFIG_SND_DMAENGINE_PCM),snd-pcm-dmaengine)
SOUNDCORE_FILES += \
- $(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko
+ $(if $(CONFIG_SND_DMAENGINE_PCM),$(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko)
endif
define KernelPackage/sound-core