aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk47
1 files changed, 46 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index f6925fe071..7c41e18fd9 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -90,6 +90,25 @@ endef
$(eval $(call KernelPackage,usb-phy-qcom-dwc3))
+define KernelPackage/phy-ath79-usb
+ TITLE:=Support for ATH79 USB PHY
+ KCONFIG:=CONFIG_PHY_AR7100_USB \
+ CONFIG_PHY_AR7200_USB
+ DEPENDS:=@TARGET_ath79
+ HIDDEN:=1
+ FILES:=$(LINUX_DIR)/drivers/phy/phy-ar7100-usb.ko \
+ $(LINUX_DIR)/drivers/phy/phy-ar7200-usb.ko
+ AUTOLOAD:=$(call AutoLoad,21,phy-ar7100-usb phy-ar7200-usb,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/phy-ath79-usb/description
+ Support for ATH79 USB transceiver
+endef
+
+$(eval $(call KernelPackage,phy-ath79-usb))
+
+
define KernelPackage/usb-gadget
TITLE:=USB Gadget support
KCONFIG:=CONFIG_USB_GADGET
@@ -313,6 +332,7 @@ define KernelPackage/usb2
+TARGET_brcm47xx:kmod-usb-ssb \
+TARGET_bcm53xx:kmod-usb-bcma \
+TARGET_bcm53xx:kmod-phy-bcm-ns-usb2 \
+ +TARGET_ath79:kmod-phy-ath79-usb \
+kmod-usb-ehci
KCONFIG:=\
CONFIG_USB_EHCI_HCD_PLATFORM \
@@ -1492,7 +1512,7 @@ $(eval $(call KernelPackage,usbip-server))
define KernelPackage/usb-chipidea
TITLE:=Host and device support for Chipidea controllers
- DEPENDS:=+USB_GADGET_SUPPORT:kmod-usb-gadget @TARGET_ar71xx +kmod-usb-ehci +kmod-usb-phy-nop
+ DEPENDS:=+USB_GADGET_SUPPORT:kmod-usb-gadget @TARGET_ar71xx||TARGET_ath79 +kmod-usb-ehci +kmod-usb-phy-nop
KCONFIG:= \
CONFIG_EXTCON \
CONFIG_USB_CHIPIDEA \
@@ -1513,6 +1533,31 @@ endef
$(eval $(call KernelPackage,usb-chipidea))
+
+define KernelPackage/usb-chipidea2
+ TITLE:=Host and device support for Chipidea2 controllers
+ DEPENDS:=+USB_GADGET_SUPPORT:kmod-usb-gadget @TARGET_ar71xx||TARGET_ath79 +kmod-usb-ehci +kmod-usb-phy-nop
+ KCONFIG:= \
+ CONFIG_EXTCON \
+ CONFIG_USB_CHIPIDEA \
+ CONFIG_USB_CHIPIDEA_HOST=y \
+ CONFIG_USB_CHIPIDEA_UDC=y \
+ CONFIG_USB_CHIPIDEA_DEBUG=y
+ FILES:= \
+ $(LINUX_DIR)/drivers/extcon/extcon.ko@lt4.9 \
+ $(LINUX_DIR)/drivers/extcon/extcon-core.ko@ge4.9 \
+ $(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc_usb2.ko
+ AUTOLOAD:=$(call AutoLoad,39,ci_hdrc_usb2,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-chipidea2/description
+ Kernel support for USB Chipidea controllers
+endef
+
+$(eval $(call KernelPackage,usb-chipidea2))
+
+
define KernelPackage/usbmon
TITLE:=USB traffic monitor
KCONFIG:=CONFIG_USB_MON