aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 19c44f805b..8f0eac7522 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1541,8 +1541,8 @@ $(eval $(call KernelPackage,usb-hid))
define KernelPackage/usb-hid-cp2112
SUBMENU:=$(USB_MENU)
TITLE:=Silicon Labs CP2112 HID USB to SMBus Master Bridge
- KCONFIG:=CONFIG_GPIOLIB=y CONFIG_HID_CP2112
- DEPENDS:=+kmod-usb-hid +kmod-i2c-core
+ KCONFIG:=CONFIG_HID_CP2112
+ DEPENDS:=@GPIO_SUPPORT +kmod-usb-hid +kmod-i2c-core
FILES:=$(LINUX_DIR)/drivers/hid/hid-cp2112.ko
AUTOLOAD:=$(call AutoProbe,hid-cp2112)
endef