aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 603bb7045c..d09cf21aba 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -273,3 +273,19 @@ define KernelPackage/pcspkr/description
endef
$(eval $(call KernelPackage,pcspkr))
+
+define KernelPackage/sound-dummy
+ $(call AddDepends/sound)
+ TITLE:=Null sound output driver (sink)
+ KCONFIG:= \
+ CONFIG_SND_DUMMY
+ FILES:= \
+ $(LINUX_DIR)/sound/drivers/snd-dummy.ko
+ AUTOLOAD:=$(call AutoLoad,32,snd-dummy)
+endef
+
+define KernelPackage/sound_dummy/description
+ Dummy sound device for Alsa when no hardware present
+endef
+
+$(eval $(call KernelPackage,sound-dummy))