aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 83d998c83a..cfd133f19f 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1126,7 +1126,9 @@ define KernelPackage/keys-trusted
TITLE:=TPM trusted keys on kernel keyring
DEPENDS:=@KERNEL_KEYS +kmod-crypto-hash +kmod-crypto-hmac +kmod-crypto-sha1 +kmod-tpm
KCONFIG:=CONFIG_TRUSTED_KEYS
- FILES:=$(LINUX_DIR)/security/keys/trusted.ko
+ FILES:= \
+ $(LINUX_DIR)/security/keys/trusted.ko@lt5.10 \
+ $(LINUX_DIR)/security/keys/trusted-keys/trusted.ko@ge5.10
AUTOLOAD:=$(call AutoLoad,01,trusted-keys,1)
endef