aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 836034ad12..3521b94d6c 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -434,6 +434,28 @@ endef
$(eval $(call KernelPackage,sit))
+define KernelPackage/fou
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=FOU and GUE decapsulation
+ DEPENDS:= \
+ +kmod-iptunnel \
+ +kmod-udptunnel4 \
+ +IPV6:kmod-udptunnel6
+ KCONFIG:= \
+ CONFIG_NET_FOU \
+ CONFIG_NET_FOU_IP_TUNNELS=y
+ FILES:=$(LINUX_DIR)/net/ipv4/fou.ko
+ AUTOLOAD:=$(call AutoProbe,fou)
+endef
+
+define KernelPackage/fou/description
+ Kernel module for FOU (Foo over UDP) and GUE (Generic UDP Encapsulation) tunnelling.
+ Requires Kernel 3.18 or newer.
+endef
+
+$(eval $(call KernelPackage,fou))
+
+
define KernelPackage/ip6-tunnel
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=IP-in-IPv6 tunnelling