aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netdevices.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/netdevices.mk')
-rw-r--r--package/kernel/linux/modules/netdevices.mk39
1 files changed, 4 insertions, 35 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 72fbb4e4e3..bf43bcb56c 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -682,7 +682,7 @@ $(eval $(call KernelPackage,igbvf))
define KernelPackage/ixgbe
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Intel(R) 82598/82599 PCI-Express 10 Gigabit Ethernet support
- DEPENDS:=@PCI_SUPPORT +kmod-mdio +kmod-ptp +kmod-hwmon-core +!LINUX_4_19:kmod-libphy
+ DEPENDS:=@PCI_SUPPORT +kmod-mdio +kmod-ptp +kmod-hwmon-core +kmod-libphy
KCONFIG:=CONFIG_IXGBE \
CONFIG_IXGBE_VXLAN=n \
CONFIG_IXGBE_HWMON=y \
@@ -720,7 +720,7 @@ $(eval $(call KernelPackage,ixgbevf))
define KernelPackage/i40e
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Intel(R) Ethernet Controller XL710 Family support
- DEPENDS:=@PCI_SUPPORT +kmod-mdio +kmod-ptp +kmod-hwmon-core +!LINUX_4_19:kmod-libphy
+ DEPENDS:=@PCI_SUPPORT +kmod-mdio +kmod-ptp +kmod-hwmon-core +kmod-libphy
KCONFIG:=CONFIG_I40E \
CONFIG_I40E_VXLAN=n \
CONFIG_I40E_HWMON=y \
@@ -744,8 +744,7 @@ define KernelPackage/iavf
CONFIG_I40EVF \
CONFIG_IAVF
FILES:= \
- $(LINUX_DIR)/drivers/net/ethernet/intel/i40evf/i40evf.ko@lt4.20 \
- $(LINUX_DIR)/drivers/net/ethernet/intel/iavf/iavf.ko@ge4.20
+ $(LINUX_DIR)/drivers/net/ethernet/intel/iavf/iavf.ko
AUTOLOAD:=$(call AutoProbe,i40evf iavf)
AUTOLOAD:=$(call AutoProbe,iavf)
endef
@@ -864,36 +863,6 @@ endef
$(eval $(call KernelPackage,hfcmulti))
-define KernelPackage/gigaset
- SUBMENU:=$(NETWORK_DEVICES_MENU)
- TITLE:=Siemens Gigaset support for isdn4linux
- DEPENDS:=@USB_SUPPORT +kmod-isdn4linux +kmod-lib-crc-ccitt +kmod-usb-core @LINUX_4_19
- URL:=http://gigaset307x.sourceforge.net/
- KCONFIG:= \
- CONFIG_ISDN_DRV_GIGASET \
- CONFIG_GIGASET_BASE \
- CONFIG_GIGASET_M101 \
- CONFIG_GIGASET_M105 \
- CONFIG_GIGASET_UNDOCREQ=y \
- CONFIG_GIGASET_I4L=y
- FILES:= \
- $(LINUX_DIR)/drivers/isdn/gigaset/gigaset.ko \
- $(LINUX_DIR)/drivers/isdn/gigaset/bas_gigaset.ko \
- $(LINUX_DIR)/drivers/isdn/gigaset/ser_gigaset.ko \
- $(LINUX_DIR)/drivers/isdn/gigaset/usb_gigaset.ko
- AUTOLOAD:=$(call AutoProbe,gigaset bas_gigaset ser_gigaset usb_gigaset)
-endef
-
-define KernelPackage/gigaset/description
- This driver supports the Siemens Gigaset SX205/255 family of
- ISDN DECT bases, including the predecessors Gigaset 3070/3075
- and 4170/4175 and their T-Com versions Sinus 45isdn and Sinus
- 721X.
-endef
-
-$(eval $(call KernelPackage,gigaset))
-
-
define KernelPackage/macvlan
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=MAC-VLAN support
@@ -1223,7 +1192,7 @@ $(eval $(call KernelPackage,sfp))
define KernelPackage/igc
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Intel(R) Ethernet Controller I225 Series support
- DEPENDS:=@PCI_SUPPORT @!LINUX_4_19
+ DEPENDS:=@PCI_SUPPORT
KCONFIG:=CONFIG_IGC
FILES:=$(LINUX_DIR)/drivers/net/ethernet/intel/igc/igc.ko
AUTOLOAD:=$(call AutoProbe,igc)