aboutsummaryrefslogtreecommitdiffstats
path: root/package/isakmpd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/isakmpd/Makefile')
-rw-r--r--package/isakmpd/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/package/isakmpd/Makefile b/package/isakmpd/Makefile
new file mode 100644
index 0000000000..a4e7ff7b03
--- /dev/null
+++ b/package/isakmpd/Makefile
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 4619 2006-08-22 09:50:02Z florian $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=isakmpd
+PKG_VERSION:=20041012
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/i/isakmpd/
+PKG_MD5SUM:=e6d25a9e232fb186e1a48dc06453bd57
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+define Package/isakmpd
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=@BROKEN @LINUX_2_6 +libopenssl +keynote +libgmp
+ TITLE:=IPsec management tools
+ URL:=http://isakmpd.sourceforge.net/
+endef
+
+define Build/Compile
+ $(call Build/Compile/Default,LINUX_DIR="$(LINUX_DIR)" \
+ STAGING_DIR="$(STAGING_DIR)" \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ )
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ STAGING_DIR="$(STAGING_DIR)" \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ INSTALL="install -c" \
+ install-bin
+endef
+
+define Package/isakmpd/install
+ install -d -m0755 $(1)/usr/sbin
+ $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+endef
+
+$(eval $(call BuildPackage,isakmpd))