aboutsummaryrefslogtreecommitdiffstats
path: root/package/hotplug2-old/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/hotplug2-old/Makefile')
-rw-r--r--package/hotplug2-old/Makefile44
1 files changed, 0 insertions, 44 deletions
diff --git a/package/hotplug2-old/Makefile b/package/hotplug2-old/Makefile
deleted file mode 100644
index ac7798acf4..0000000000
--- a/package/hotplug2-old/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=hotplug2-old
-PKG_VERSION:=0.9
-PKG_RELEASE:=3
-
-PKG_SOURCE:=hotplug2-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
-PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/hotplug2-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/hotplug2-old
- SECTION:=base
- CATEGORY:=Base system
- VERSION:=0.9+r102-$(PKG_RELEASE)
- TITLE:=Dynamic device management subsystem for embedded systems
- URL:=http://isteve.bofh.cz/~isteve/hotplug2/
-endef
-
-define Package/hotplug2-old/description
- Hotplug2 is a trivial replacement of some of the UDev functionality
- in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
-endef
-
-MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES -I."
-
-define Package/hotplug2-old/install
- $(INSTALL_DIR) $(1)/etc
- $(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
- $(INSTALL_DIR) $(1)/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
-endef
-
-$(eval $(call BuildPackage,hotplug2-old))