aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/linux-firmware/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/firmware/linux-firmware/Makefile')
-rw-r--r--package/firmware/linux-firmware/Makefile29
1 files changed, 7 insertions, 22 deletions
diff --git a/package/firmware/linux-firmware/Makefile b/package/firmware/linux-firmware/Makefile
index fe682aba3d..a4b081a517 100644
--- a/package/firmware/linux-firmware/Makefile
+++ b/package/firmware/linux-firmware/Makefile
@@ -29,10 +29,6 @@ define Package/r8169-firmware
TITLE:=RealTek r8169 firmware
endef
-define Build/Compile
-
-endef
-
define Package/r8169-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/rtl_nic
$(CP) \
@@ -40,8 +36,6 @@ define Package/r8169-firmware/install
$(1)/lib/firmware/rtl_nic
endef
-$(eval $(call BuildPackage,r8169-firmware))
-
define Package/r8188eu-firmware
SECTION:=firmware
CATEGORY:=Firmware
@@ -49,10 +43,6 @@ define Package/r8188eu-firmware
TITLE:=RealTek r8188eu firmware
endef
-define Build/Compile
-
-endef
-
define Package/r8188eu-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/rtlwifi
$(CP) \
@@ -60,8 +50,6 @@ define Package/r8188eu-firmware/install
$(1)/lib/firmware/rtlwifi
endef
-$(eval $(call BuildPackage,r8188eu-firmware))
-
define Package/ibt-firmware
SECTION:=firmware
CATEGORY:=Firmware
@@ -69,10 +57,6 @@ define Package/ibt-firmware
TITLE:=Intel bluetooth firmware
endef
-define Build/Compile
-
-endef
-
define Package/ibt-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/intel
$(CP) \
@@ -80,8 +64,6 @@ define Package/ibt-firmware/install
$(1)/lib/firmware/intel
endef
-$(eval $(call BuildPackage,ibt-firmware))
-
define Package/ar3k-firmware
SECTION:=firmware
CATEGORY:=Firmware
@@ -89,10 +71,6 @@ define Package/ar3k-firmware
TITLE:=ath3k firmware
endef
-define Build/Compile
-
-endef
-
define Package/ar3k-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/ar3k
$(CP) \
@@ -100,4 +78,11 @@ define Package/ar3k-firmware/install
$(1)/lib/firmware/ar3k
endef
+define Build/Compile
+
+endef
+
$(eval $(call BuildPackage,ar3k-firmware))
+$(eval $(call BuildPackage,ibt-firmware))
+$(eval $(call BuildPackage,r8169-firmware))
+$(eval $(call BuildPackage,r8188eu-firmware))