aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/dnsmasq/Makefile')
-rw-r--r--package/dnsmasq/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index baa48d579e..467c93494e 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
-PKG_VERSION:=2.62
-PKG_RELEASE:=3
+PKG_VERSION:=2.66
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=f47e5cb8f5bac6343f24b2dbe317ab40
+PKG_MD5SUM:=c5eb8fb88847a5e9bf18db67c74efd47
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILES:=COPYING
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -60,7 +63,7 @@ Package/dnsmasq-dhcpv6/conffiles = $(Package/dnsmasq/conffiles)
TARGET_CFLAGS += \
-ffunction-sections -fdata-sections \
- $(if $(CONFIG_IPV6),,-DNO_IPV6)
+ $(if $(CONFIG_IPV6),,-DNO_IPV6) -DNO_IPSET -DNO_AUTH
ifeq ($(BUILD_VARIANT),nodhcpv6)
TARGET_CFLAGS += -DNO_DHCP6