aboutsummaryrefslogtreecommitdiffstats
path: root/package/devel/valgrind/patches/200-musl_fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/devel/valgrind/patches/200-musl_fix.patch')
-rw-r--r--package/devel/valgrind/patches/200-musl_fix.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/devel/valgrind/patches/200-musl_fix.patch b/package/devel/valgrind/patches/200-musl_fix.patch
index 23d74e0caf..c6e6a6628f 100644
--- a/package/devel/valgrind/patches/200-musl_fix.patch
+++ b/package/devel/valgrind/patches/200-musl_fix.patch
@@ -1,8 +1,8 @@
--- a/coregrind/vg_preloaded.c
+++ b/coregrind/vg_preloaded.c
-@@ -56,7 +56,7 @@
- void VG_NOTIFY_ON_LOAD(freeres)( void );
- void VG_NOTIFY_ON_LOAD(freeres)( void )
+@@ -57,7 +57,7 @@
+ void VG_NOTIFY_ON_LOAD(freeres)(Vg_FreeresToRun to_run);
+ void VG_NOTIFY_ON_LOAD(freeres)(Vg_FreeresToRun to_run)
{
-# if !defined(__UCLIBC__) \
+# if !defined(__UCLIBC__) && defined(__GLIBC__) \
@@ -11,7 +11,7 @@
&& !defined(VGPV_mips32_linux_android) \
--- a/include/pub_tool_redir.h
+++ b/include/pub_tool_redir.h
-@@ -242,7 +242,7 @@
+@@ -243,7 +243,7 @@
/* --- Soname of the standard C library. --- */
#if defined(VGO_linux) || defined(VGO_solaris)
@@ -20,7 +20,7 @@
#elif defined(VGO_darwin) && (DARWIN_VERS <= DARWIN_10_6)
# define VG_Z_LIBC_SONAME libSystemZdZaZddylib // libSystem.*.dylib
-@@ -274,7 +274,11 @@
+@@ -275,7 +275,11 @@
/* --- Soname of the pthreads library. --- */
#if defined(VGO_linux)
@@ -34,7 +34,7 @@
#elif defined(VGO_solaris)
--- a/configure.ac
+++ b/configure.ac
-@@ -1066,8 +1066,6 @@ case "${GLIBC_VERSION}" in
+@@ -1047,8 +1047,6 @@ case "${GLIBC_VERSION}" in
;;
2.0|2.1|*)
AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])